Back to overview
Downtime
IEC Kelio Down
Jan 31 at 05:30pm CET
Affected services
Kelio - iecmytime.kelio.io
Resolved
Feb 01 at 05:02am CET
The service is now back to normal activity.
Affected services
Kelio - iecmytime.kelio.io
Created
Jan 31 at 05:30pm CET
Our external supplier is experiencing issues with their provider.
Affected services
Kelio - iecmytime.kelio.io