Unexpected load on IEC Core Database
Resolved
Mar 18 at 07:06pm CET
All services are now back to normal activity.
Affected services
Created
Mar 18 at 12:34pm CET
We are experiencing an unexpected load increase on our IEC Core database, resulting in delays and some services operating in a degraded mode. Our team is actively working to resolve the issue as quickly as possible. Thank you for your patience.
Affected services