Back to overview
Degraded
IECEx online certificate system Issues
Mar 10, 2026 at 07:00am UTC
Affected services
OCS IECEX - iecex-certs.com
Resolved
Mar 10, 2026 at 03:39pm UTC
Incident is now closed and the IECEX Online certificate system is working correctly.
Affected services
Created
Mar 10, 2026 at 07:00am UTC
We are currently experiencing issues accessing certificates in the IECEx online certificate system. Our team is actively working to resolve the problem as quickly as possible.
We apologize for the inconvenience and appreciate your patience.
Affected services